SAP Knowledge Base Article - Public

3359686 - Mobile App: No Tiles on Launchpad - Home

Symptom

No tiles appear for Mobile User on the Mobile App

Environment

SAP Business ByDesign Mobile Application

Reproducing the Issue

  1. Login to ByD Mobile App
  2. No tiles appear on the Launchpad - Home

Cause

User may have PDI related permissions.

PDI related permissions on the User can interfere with the Mobile App, and prevent the tiles generating correctly.

Resolution

Remove the PDI permissions from the User, login to the Mobile App and everything should load as expected.

Once the system has successfully generated the Home tiles, you can now re-add the PDI permissions and these should now load correctly as well.

Please note that this issue can occur in two scenarios;

  • When a User has changes made to their Permissions that involve both PDI and non PDI Permissions.
  • When major system changes are made, including the quarterly Updates to ByD.

As such we would recommend having a specific non-PDI Business Role available to easily resolve the issue

See Also

KBA: 3361001   Mobile App Users are redirected to the Desktop UI Screen

Keywords

not, possible, visible, missing, access restrictions, Business role, tiles, blank, launchpad, homepage, PDI,  , KBA , SRD-CC-MOB , Mobile Framework , Problem

Product

SAP Business ByDesign all versions