Symptom
When calling CPQ from a SOAP call the result of the request is "invalid login" error as below example:
"<doUSeeMeResult><NO><REASON>Invalid login</REASON></NO></doUSeeMeResult>".
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Open SOAP UI or Postman;
- Create a request for SOAP API "DoUSeeMe";
- In Authorization window create a new authorization;
- Select Basic and hit OK;
- Select checkbox for "Use Global preference";
- Input password and Login;
- Run the API and Check XML response.
Cause
Authenticate preemptively is not properly enabled in SOAP UI.
Resolution
Authenticate preemptively needs to be enabled following below path:
- Preferences;
- Http Settings (first option);
- Authenticate Preemptively;
- Check the box for "Adds authentication information to outgoing request".
Keywords
CPQ, SOAP, UI, request, response, invalid, login, error, authentication, preemptively , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error
Product
SAP CPQ 2023