SAP Knowledge Base Article - Public

3360457 - Solution Activation is Failing due to Failed to Activate Items

Symptom

Errors while activating Uploaded PDI solution.

Failed to activate items of type ReferencestoCustomer-SpecificFields

Type of field XXX does not match (expected: ABC, found: PQR)

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

  1. Go to Cloud Application Studio
  2. Open affected solution Y123AXXX - (Y123AXXX stands for PDI solution)
  3. Click on activate
  4. Error appears

      Failed to activate items of type ReferencestoCustomer-SpecificFields

     Type of field XXX does not match (expected: ABC, found: PQR)

 

Cause

The source system has the data type of (ABC) where as the target system has the data type of (PQR).Hence, being the reason why the conflict of data type this error is coming.The source system has the data type of (ABC) where as the target system has the data type of (PQR).Hence, being the reason why the conflict of data type this error is coming.

Resolution

Ideally, partner should not change the field's data type. To fix this issue both source and target of the affected fields should be with same DATATYPE.

 OPTION 1

1. Create a new patch in the source system .
2. Uncheck this field from the .ref file in the source system.
3. Perform check consistency and then   
4. Perform a complete assembly of this new patch in the source system.
5. Deploy the new patch in the target system.
6. Delete and re-create the KUT field in the target system with (ABC)
7. Create another patch in the source system.
8. Check this field in the .ref file in the source system.
9. Ensure the field is with no exist.
10.Perform a complete assembly of this final patch in the source system.
11.And finally deploy the new patch in the target system.

OPTION 2. 

Revert the data type in the source system to (PQR) by deleting and re-creating the field.

If they want to go with this approach, they will have to :
1. create a new patch in the source system .
2. uncheck this field from the .ref file in the source system.
3. Delete and re-create the KUT field in the source system with (PQR)
4. Perform a complete assembly of this new patch in the source system.
5. Deploy the new patch in the target system.

See Also

https://help.sap.com/docs/SAP_CLOUD_APPLICATIONS_STUDIO/cbcebe3cfb1647a8b0322c18dbb0b481/759b4cbf73e21014a35ef9d0e04a7f3e.html

Keywords

Activation failed;KUT;DATATYPE, ReferencestoCustomer-SpecificFields. , KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , BC-DWB-REP-EXT , Extensibility , AP-RC-BDS-EXT , ByDesign Studio Extensibility , How To

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions