SAP Knowledge Base Article - Public

3360559 - The workflow rule with a push notification cannot be triggered

Symptom

When sending a document for approval or working out a workflow rule, the end user receives a notification in the bell. However, end users do not receive push notifications on their mobile devices.

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Customer Extended App

Reproducing the Issue

  1. For an example create a workflow rule with push notification enabled for a new task
  2. Login to SAP Cloud for Customer Extended App
  3. Click on "More" and go to "Task" work center view
  4. Create a new task and click on "Save"
  5. A new notification displayed in the "Notifications" bell, but no push notification triggered

Cause

Send Push Notification button not checked in Workflow Rule editing.

Resolution

Check the Send Push Notification button in Workflow Rule editing.

  1. Go to Administrator work center
  2. Go to Workflow Rules work center view
  3. Select the Workflow rule and click on Edit
  4. Next to step 3 Define Actions
  5. Check the Send Push Notification button
  6. Next and Finish to save the changes

See Also

  1. 2771460 - How To Activate Push Notifications For Mobile Devices
  2. 3317839 - Notification in C4C Mobile apps is not pushed to Mobile Phone's home screen
  3. 2898536 - Push notification is not triggered

Keywords

Push Notification, mobile, mobile APP, Approval, Workflow Rule, iPhone , KBA , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications all versions