Symptom
You are trying to do import multiple records for one user (via API or UI) on Job Information, and expect the changes to trigger respective workflow but you are getting the below error message:
"You cannot import multiple records for one user if any of these records will trigger a workflow. Try to disable the relevant business rule assigned to the object or avoid importing multiple records at one time"
Environment
SAP SuccessFactors Employee Central
Cause
When multiple records on same user are imported and any of them is trying to trigger a workflow, the import on that specific user is blocked.
If we also have other records on other users in same import transaction, those records will not be blocked and still proceed.
Resolution
This is a system behavior and is working as expected. You have to make sure the workflow is handled separately.
This is described on Configuring Workflows for Data Imports guide, under Employee Central.
See Also
Keywords
workflow, import, upsert, odata, employee central, ec, business rule, job history, job information , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , How To