SAP Knowledge Base Article - Public

3360791 - SAP Fiori Launchpad Search does not deliver results - SAP S/4HANA Cloud

Symptom

  • You are using the SAP Fiori Launchpad Search.
  • You are not able to find any app the second time you enter a search term in the SAP Fiori Launchpad Search.

Environment

SAP S/4HANA Cloud 2308

Reproducing the Issue

  1. Login to SAP S/4HANA Cloud system
  2. Use the SAP Fiori Launchpad search to search for an app
  3. Navigate to the app and perform any action.
  4. Click on the home button and navigate back to the Fiori Launchpad Home page
  5. Use the SAP Fiori Launchpad search to search for another app
  6. No results found

Cause

Due to a UI5 container rendering issue, if user re-enter the search app from other launchpad apps, the search result list container is shortly rendered with height 0 and width 0. However, app search tiles are removed according to the container size of 0 and will not be re-rendered, so that user can only see the result count without any app tiles.

Resolution

A fix for this issue has been provided and will be delivered with HFC03(19-20.08)

Fore more information, please check

SAP S/4HANA Cloud, Public Edition, 2-System Landscape – Upgrade & Maintenance Schedule

SAP S/4HANA Cloud, Public Edition, 3-System Landscape – Upgrade & Maintenance Schedule

As a workaround, if you do not get any search result, you just need to re-enter the same search term once again and the result should be displayed properly.

Keywords

fiori launchpad search, sap fiori launchpad search, flp search, 2nd, again  , KBA , HAN-AS-INA-UI , SAP HANA InA Toolkit, Fiori Search UI , CA-FLP-FE-UI , SAP Fiori Launchpad User Interface , CA-FLP-ABA , SAP Fiori Launchpad ABAP Services , CA-FLP-FE-COR , SAP Fiori Launchpad Frontend Core and Services , Problem

Product

SAP S/4HANA Cloud 2308