SAP Knowledge Base Article - Public

3361001 - Mobile App Users are redirected to the Desktop UI Screen

Symptom

The desktop UI is invading the Mobile App for the users with access to self-service which opens to My Launchpad and the screen appears unfamiliar. Scroll down to Self-Services Overview, and the page opens with no active icons to access Timesheet.

Environment

  • SAP Business ByDesign

Reproducing the Issue

  1. Login to the SAP Business ByDesign Mobile App
  2. Observe, the UI displayed in the mobile application is incorrect

Cause

The user does not have the corresponding access to the Work Center view

Resolution

The user has to maintain the corresponding desktop Work Center View assigned on desktop UI. If this is the case, to get a tile into the mobile launchpad follow the below steps:

In case you did no manual adoption for the tiles on the screen, the easiest way is to follow the below steps.

1. Navigate to the User Profile on the top left corner
2. Select on Personalize
3. Select the User Profile icon on the top right corner
4. Select on Discard
5. Choose Confirm
6. Select the User Profile icon on the top right corner again
7. Tap on stop personalization mode

The screen should be refreshed and there should be a group shown (e.g. Field and Service Repair with tile Order Pipeline)
In case you did already manual adoption for the tiles on this screen, please follow the below steps:

1. Select the User Profile on the top left corner.
2. Select on Personalize
3. Select Plus Icon on the Group you would like to have the tile
4. Search for the "missing" tile (e.g. Order Pipeline)
5. Select the pin item of the tile

Keywords

Mobile App, Desktop UI, Self-Service Overview , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , Problem

Product

SAP Business ByDesign all versions