SAP Knowledge Base Article - Public

3361010 - Error with Skills mapped to entities in Job Profile Builder (Check ID: MustNotHaveSkillMappingsWithNullWsmIdCheck) - Talent Intelligence Hub

Symptom

When running the checks for Talent Intelligence Hub application in Admin Center > Check Tool, issue for the check "MustNotHaveSkillMappingsWithNullWsmIdCheck" can be found.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Talent Intelligence Hub

Cause

  • A mapping exists in Talent Intelligence Hub for unsupported skills
  • SalesDemo environments ONLY - Engineering deleted the workflow 

Resolution

I. A mapping exists in Talent Intelligence Hub for unsupported skills

Back up all skills and skill-associated data from your instance by exporting Skills files (including mappings)

  1. Navigate to Admin Center > Import and Export Data
  2. In
  3. Locate Skill
  4. Select export all files with skill and skill mappings:
    • Family-Family Skills
    • Job Profile Draft-skillContents
    • Job Profile-Skills
    • Position Extension-Position Skills
    • Role-Mapped Skills
    • Skill 
    • Skill Profile-Rated Skills
    • Skill Profile-Self Report Skills
  5. Remove all skills associated with roles, families, and positions using the "Delimit" option in the exported skills files
  6. Save the new file
  7. Navigate to Admin Center > Import and Export Data
  8. In
  9. Locate Skill and select the applicable skill object
  10. Browse for the file you saved and select it for upload
  11. Select Validate > Import

After the Talent Intelligence Hub migration is completed, re-create the skills in Talent Intelligence Hub following the steps in Using Talent Intelligence Hub - Creating an Attribute Type. Associate the skills created in Talent Intelligence Hub with roles, families, and positions in Admin Center > Manage Job Profile Content.

II. SalesDemo environments ONLY - Engineering deleted the workflow

Please create a case with Product Support under component LOD-SF-TIH-MIG so engineering can run a script to fix the Check Tool error. The following details will be required to process the script:

  • Pictures showing all JDM and JPB Check Tool errors have been resolved
  • Data Center (URL of your login screen):
  • Company Instance ID (where to apply changes):
  • Approval

Still Need Help?

If you need assistance with the migration, customers can exchange experiences with each other and ask questions of our migration and adoption experts in a new Work Zone group. In order to be admitted into the group, please send an email to SAP_SF_Product_Advisory@sap.com. All group members will also be invited to Office Hours calls, that will take place from time to time, and according to necessity. More information is posted in Everything you need to know about: SAP SuccessFactors Talent Intelligence Hub.

See Also

Keywords

TIH, migration, Talent Intelligence Hub, Must Not Have Skill Mappings With Null Wsm Id Check, Skills are not mapped to entities in Job Profile Builder, success factors, sf, sfsf , KBA , LOD-SF-TIH-MIG , Migration to Talent Intelligence Hub , Problem

Product

SAP SuccessFactors HCM suite all versions