SAP Knowledge Base Article - Public

3361029 - Error with missing competencies data in the mapping table (Check ID: MissingCompetencyJpbIdsInMappingEntityCheck) - Talent Intelligence Hub

Symptom

When running the checks for Talent Intelligence Hub application in Admin Center > Check Tool, issue(s) for the check "MissingCompetencyJpbIdsInMappingEntityCheck" can be found.

Environment

SAP SuccessFactors Talent Intelligence Hub

Cause

During Center of Capabilities to Talent Intelligence Hub migration, a mapping entity is created to store the Center of Capabilities and Talent Intelligence Hub reference IDs. Sometimes, due to technical issues, mapping for some of the competency references from Center of Capabilities is not created in the system.

Resolution

Some checks have a Quick Fix, which can be used to immediately correct any issues found by that check.
NOTE: Keep a backup of your data before using the Quick Fix option to correct this issue, by exporting the Competency-Behavior file with existing data in Import and Export Data tool.

Quick Fix option is available for this check, and users with permission "Allow Check Tool Quick Fix" granted in RBP can:

  1. Click the results and will see the four-step process at the top of the Detailed Results dialog;
  2. Complete all four steps to fix the sequence issue, providing your approval for the data selected, and click Close to complete the process;
    NOTE: Procedure can be found in the Using the Quick Fix Feature section of the Check Tool Guide,
  3. Run the check again to verify if the fix was completed successfully;
  4. Once completed, competency mapping entries will be automatically populated for missing ones in JdmJpbMapping table.

NOTE: When the Quick Fix tool does not work, we can resolve the issue directly via Manage Data tool:

1. Copy paste external codes (GUIDs) of those competencies
2. Go to Manage Data and select competency
3. Paste external codes and then select take action > make correction
4. Edit the competency name, add a dot at the end of the name
5. Save the changes

Still Need Help?

If you need assistance with the migration, customers can exchange experiences with each other and ask questions of our migration and adoption experts in a new Work Zone group. In order to be admitted into the group, please send an email to SAP_SF_Product_Advisory@sap.com. All group members will also be invited to Office Hours calls, that will take place from time to time, and according to necessity. More information is posted in Everything you need to know about: SAP SuccessFactors Talent Intelligence Hub.

See Also

Keywords

JDM, JPB, TIH,CofC, migration, Job Profile Builder, Job Description Manager, Center of Capabilities, Talent Intelligence Hub, MissingCompetencyJpbIdsInMappingEntityCheck, Missing competencies data in the mapping table , KBA , LOD-SF-TIH-MIG , Migration to Talent Intelligence Hub , Problem

Product

SAP SuccessFactors HCM suite all versions