SAP Knowledge Base Article - Public

3361877 - National id error: "Invalid entry for isPrimary" - Employee Central

Symptom

Error while saving national id for employee:
 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP Employee Central

Reproducing the Issue

  1. Go to Employee Profile
  2. Go to National Id portlet
  3. Click edit and on save you will find following error: "Invalid entry for isPrimary. Please enter “t” or “y” for true, or “f” or “n” for false. Note that this field is not case sensitive."

Cause

The "isPrimary" field is disabled in the instance, however this is a required field and should be configured as explained in guide:

https://help.sap.com/docs/SAP_SUCCESSFACTORS_EMPLOYEE_CENTRAL/213711b5e5a847e2a20dfdd465346252/b0cf99b7a9fa419f8d6f556778b69a19.html?locale=en-US&version=2305&q=national%20id

Resolution

As solution please enable the isPrimary field:

  1. Go to Manage Business Configuration
  2. Click on nationalIdCard entity
  3. Add the "isPrimary" field
  4. Save.

See Also

https://help.sap.com/docs/SAP_SUCCESSFACTORS_EMPLOYEE_CENTRAL/213711b5e5a847e2a20dfdd465346252/b0cf99b7a9fa419f8d6f556778b69a19.html?locale=en-US&version=2305&q=national%20id

Keywords

"Invalid entry for isPrimary. Please enter “t” or “y” for true, or “f” or “n” for false. Note that this field is not case sensitive" invalid, is primary, primary, error, national, id, unable, save, validation, , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HXM Suite all versions