SAP Knowledge Base Article - Public

3363304 - OData API: filtering on userAccountNav/accountStatus throws error [COE0019]Failed to retrieve result with given criteria.

Symptom

When navigating to the UserAccount entity in your OData API query and filtering on the account status property:

  • e.g. $filter=personNav/userAccountNav/accountStatus eq 'ACTIVE' 

 

You receive the below error in the API response:

  • [COE0019]Failed to retrieve result with given criteria.

 

The same behaviour is encountered in Integration Center when using the same filter

  

Environment

  • SAP SuccessFactors HXM Suite
    • OData API
         

Reproducing the Issue

Perform OData API query which navigates from Employee Central entity (e.g. PerPersonal) to the UserAccount entity

& filters on accountStatus property (e.g. $filter=personNav/userAccountNav/accountStatus eq 'ACTIVE')

   

Cause

$filter=personNav/userAccountNav/accountStatus eq 'ACTIVE' is a cross-module filter (from PerPersonal to UserAccount). 

For the entity UserAccount, there is special handling for the filter accountStatus eq 'ACTIVE'.

   

Resolution

As a workaround, you can instead use: $filter=personNav/userAccountNav/accountStatus eq 0 

  • 0 stands for ACTIVE
  • 1 stands for INACTIVE 
        

Keywords

UserAccrount, userAccountNav, cross-module, filter, accountStatus, ACTIVE, INACTIVE, COE0019 , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors HCM suite all versions