SAP Knowledge Base Article - Public

3363430 - Mass Schedule Onboarding Meetings task sending wrong email to candidates - Onboarding

Symptom

Once using the "Mass Schedule Onboarding Meetings" task to invite candidates to the same meeting, some candidates are receiving email supposed to be addressed only for Participants.

Candidates are not supposed to receive email with other candidates' information.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Under to-do dropdown click to start the "Mass Schedule Onboarding Meetings"
  2. Select many candidates and arrange a meeting
  3. Now go to Email Services
  4. Note that the meeting responsible user receives the email with candidates' information, but the same email is also sent to a/some candidate(s).

Cause

A New Hire already converted to Internal Employee is selected as a candidate to be part of the meeting.

Resolution

When the participant emails are getting created, we refine the users out if they are external users and if they do match the same subject user of the meeting activity.

If the affected New Hire is already an internal employee, and is getting added to participant emails for the other onboardee participant emails, as this user is no longer external user and also not the subject user for the meeting activity task of the other onboardees. Thus, please select only valid external users (new hires) when mass scheduling of onboarding meetings.

How to confirm if the candidate is already an internal employee? In Data Inspector for users sysinfo table, check the affected candidate receiving improper email if flag shows as "t". 

Keywords

Mass, Schedule, Onboarding, Meetings, task, send, candidate, incorrect, wrong, information, email, notification, obx, onboarding, participants , KBA , LOD-SF-OBX-NHA , New Hire Activities (activities, tasks, buddy, equipment) , Problem

Product

SAP SuccessFactors Onboarding all versions