Symptom
After the upgrade to SAP S/4HANA Cloud 2308, custom fields with business scenario enabled (e.g. Service Transactions to Pricing Communication at Item Level) for service transactions (e.g. service contract, service order, service confirmation, solution order, in-house repair) cannot be maintained in apps or APIs such as "Manage Service Contracts", "Manage Service Orders", SOAP API Service Contract - Create, Update (Asynchronous) (SAP_COM_0436), ODATA V4 API Service Contract (A2X) (SAP_COM_0789), Service Order - Create, Change (Asynchronous) (SAP_COM_0424), ODATA V2 Service Order (A2X) (SAP_COM_0350), etc.
Environment
- SAP S/4HANA Cloud CE2308
- CRM Service Management
Reproducing the Issue
- Logon to the Launchpad with role SAP_BR_CUSTOMER_SRVC_MGR assigned.
- Open the app "Manage Service Contracts" (taking service contract as an example here).
- Create a service contract.
- Input values into the custom fields (with business scenario enabled).
- Click on "Enter".
- The maintained values of the custom fields are automatically removed.
Cause
Due to a coding issue, the input values provided to custom fields are automatically removed before the save of the service transactions.
Resolution
The issue is to be resolved by SAP S/4HANA Cloud 2308 HFC03. Please implement the respective upgrade to get the correct functionality.
Keywords
SRV, own fields, Y_, Service contract, Service order, Service confirmation, Solution order, In-house repair, F3763, F3571A, CRMS4_SERV_CONTRACT_MANAGE_SRV, MSC_MANS1, SERVICECONTRACTREQUEST_IN, CE_SERVICECONTRACT_0001 , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem
SAP Knowledge Base Article - Public