SAP Knowledge Base Article - Public

3363702 - Delivery Block Maintained in an Account is Not Taken Over in a new Sales Order or Service Order.

Symptom

You are creating a Sales Order or Service Order by copying an existing Sales Order or Service Order the  Delivery Block (in case of Sales Orders) or the Execution Block (in case of Service Orders) is not set, however it is maintained as a Delivery Block for the particular Account in the Account Master Data.

Environment

SAP Business ByDesign

Reproducing the Issue

This applies for both Sales Order and Service Order. We will use a Service Order as an example:

  1. Go to the Service Order work center.
  2. Select the Service Order processing view.
  3. Choose the Service Order XYZ and click on Copy button (XYZ represents previously created service order where delivery block was not set).
  4. Execution Block is empty in the new copied Service Order.

Cause

The new service order fetches the data from copied service order XYZ (XYZ represents the completed service order) and not from Account master data.

Resolution

This is the expected behavior of the SAP Business ByDesign system.

As a work around, you need to perform a dummy change in the new service order. Please follow below steps:

  1. Go to Account and Affected Product tab in service order.
  2. Account: Choose any other account.
  3. Add the same Account again which was previously used.
  4. Now you can see the Execution block is set for document.

See Also

Keywords

Sales Order' Service Order, Delivery Block, Execution Block, Copy, Account , KBA , AP-SVO-SO , Service Order , Problem

Product

SAP Business ByDesign all versions