SAP Knowledge Base Article - Public

3364148 - Groupware Setting Changes Are Not Reflecting in G-Mail Add-In

Symptom

You have certain dropdown fields in G-Mail for which values need to be restricted as per restrictions defined.

However, the fields are not being restricted as expected.

For example, a user has done changes to field "Account Type" in add-in settings under "Account" card. They have checked all boxes to make the field "Required", "Read Only" and "Display on Create".

However, when they log in to their G-mail integration, the field does not have any of these requirements.

Environment

SAP Cloud for Customer

Reproducing the Issue

    1. Log into e-mail Server side.
    2. Look into the fields specified.
    3. You will notice that the fields are not being restricted as per the restrictions defined.

    Cause

    There are 2 situations which can explain why this happens:

    1. Read-Only indicates whether a field’s value can be modified. It is not related to assigning an initial value for such field. It cannot be modified.
    2. Greyed out entities such as Account, Contact, etc. It cannot be removed since they are the main object.

    Resolution

    This feature is not supported as of now.

    As it is a behavior of the system, we suggest you to raise an idea in the SAP Sales Cloud Portal requesting this functionality. The Customer Influence portal is the correct channel for requirements of changes in the system behavior.

    There, other customers can also vote for the idea and depending on the demand from the customer community, the developers will evaluate and plan accordingly for a possible implementation of this new feature.

    Keywords

    Code List Restriction, CLR, G-mail, server side; , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To

    Product

    SAP Cloud for Customer core applications 2308