Symptom
Email conversations are missing in AskHR under My Tickets > Conversation > Email Conversation. However, they appear in the interactions on C4C side.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Employee uses any email to send a message to C4C;
- The agent then converts the email received in a C4C ticket;
- The interaction happens between the C4C agent through the email sent in step one;
- In AskHR under Email Conversations it was expected to see these interaction but this is not happening;
Cause
There are some possible causes:
- The missing conversations in AskHR were sent to emails that are not linked to the related employee ID in C4C;
- Different employees has the same email address in C4C;
- The SAP UI5 version is not supported by AskHR (e.g. 1.108);
Resolution
Here follows the resolution for each cause:
- Expected Behavior: In C4C is allowed only one email to be associated with the employee ID and this is the information used by AskHR to display the email conversations. Although C4C shows everything under the interactions, AskHR will only display interactions that happens via the email linked to the employee ID;
- Avoid registering the same email for different employees in C4C;
- Update the SAP UI5 version to a current supported one (e.g. 1.96) (refer to this chapter);
Keywords
email, emails, conversation, conversations, interaction, interactions, askhr, view, different, personal, business, miss, missed, missing , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem
Product
SAP SuccessFactors HCM Suite all versions