Symptom
You have certain dropdown fields in G-Mail for which values need to be restricted as per the code list restrictions defined.
However, the fields are not being restricted as expected.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Log into C4C.
- Create a code list restriction for specific fields.
- NO issues creating it.
Now:
- Log into G-mail Server side.
- Look into the fields specified in CLR.
- You will notice that the fields are not being restricted as per the code list restrictions defined.
Cause
There are 2 situation which can explain why this happens:
- Read-Only indicates whether a field’s value can be modified. It is not related to assigning an initial value for such field. Once the initial value is entered, in read-only state, it cannot be modified.
- Greyed out entities such as Account, Contact, etc cannot be removed since they are main object. This is expected behavior.
Resolution
This feature is not supported as of now.
As it is a behavior of the system, we suggest you to raise an idea in the SAP Sales Cloud Portal requesting this functionality. The Customer Influence portal is the correct channel for requirements of changes in the system behavior. There, other customers can also vote for the idea and depending on the demand from the customer community, the developers will evaluate and plan accordingly for a possible implementation of this new feature.
Keywords
Code List Restriction, CLR, G-mail, server side; , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Known Error