SAP Knowledge Base Article - Public

3364878 - "Authorization Code Not Available" Error in User Registration for OAUTH2 Web Services

Symptom

You are trying to setup a Concur integration with SAP Business ByDesign, however upon trying to register a user for OAuth to perform the integration tasks, the Access Permission Status column shows a red icon, and when hovering the icon the following message appears:

"Authorization Code Not Available".

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Application and User Management work center.
  2. Enter the User Registrations for OAUTH2 Web Services work center view.
  3. Select the CONCUR_INTEGRATION_OAUTH_JWT service provider entry.

In the table that appears below, you can see the users with the mentioned Access Permission Status icon.

Even if the correct access key is set for the user according to the integration guide, there is no change in the user status.

 

Cause

The issue is caused due to an incorrect API server link configured in the Business Configuration activity Integration with Concur Solutions.

As an example, if your Concur server URL is "https://eu2.concursolutions.com", it should be maintained in the business configuration as "https://eu2.api.concursolutions.com".

Furthermore, please ensure that the Concur Integration communication "Concur Integration (JWT)" is not isolated.

Resolution

To check and adjust the configuration, please follow the steps below:

  1. Go to the Business Configuration work center.
  2. Enter the Implementation Projects view.
  3. Select your current implementation project and click on Open Activity List.
  4. Search for the activity Integration with Concur Solutions and open it.
  5. In the Service Provider table, select the entry CONCUR_INTEGRATION_OAUTH_JWT.
  6. Click on the button Register Client.
  7. In the API Server URL and Authentication Server URL fields, maintain the Concur URL as described in the example above (inserting ".api." after the server identifier of the URL).
  8. Click on the button Save and Close.

To check the communication arrangement, please follow the below steps:

  1. Go to the Application and User Management work center.
  2. Enter the Communication Arrangements view.
  3. Search and select communication arrangement Concur Integration (JWT).
  4. Click on the De-isolate button.

After checking the steps above, you can try to re-register the user (by removing it, and then re-entering the user again).

See Also

Replicating Data After SAP Business ByDesign Client Copy

Keywords

ECC, Concur, Client, Replication, Token , KBA , AP-INT-GEN , Reuse parts of the DU Integration Orchestration , Problem

Product

SAP Business ByDesign 2305