Symptom
When using % in filtering by some quote item custom field (QICF), OK button is still inactive in Filters pop-up.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Login to CPQ
- Create a quote item custom field and select Use column value to filter quote items.
- Select the quote item custom field in Quote Layout
- Make the quote item custom field visible to users in Quote Layout Permissions.
- Add a value to quote item custom field, say 'api'
- Add couple of product to quote
- User Side : Clicking on the Filter Items button opens the Filters pop-up with the filtering criteria. All quote item custom fields that are enabled for filtering are displayed in the pop-up.
- In the pop-up, for the test quote item custom field, enter '%some text(say ap)
- Filtering doesn't work, OK button is still inactive
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Cause
- Depending on the type of the quote item custom field, users can enter, pick a value, or set a range of minimum and maximum values. The logic between multiple filters is AND.
- Per design, you can select which values you want to filter by.
- Using % as filter does not work.
Resolution
It is per design that you can't use % in filtering by some quote item custom field even if it's type of Text.
See Also
Keywords
Cannot filter by %, Percentage, Quote item custom field, QICF, Filtering, Filters, OK button inactive, %, AND logic , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions
Attachments
Pasted image.png |
Pasted image.png |