Symptom
You are able to save Alphabets in Phone Number field.
Environment
- SAP Sales Cloud Version 2
- SAP Sales and Service Cloud Version 2
Reproducing the Issue
- Navigation Menu.
- Go to Accounts View.
- Open Account 123 (where 123 is the account ID).
- In the Phone field, enter alphabetic letters (e.g. ABC).
- The Phone Number is saved successfully.
Cause
The alphanumeric or Alphabetical values are valid and required in some cases.
The system only checks the entry for special characters such as "<>.,!§% &(@€". If you enter these characters the system will remove them from the field as they are not valid.
Resolution
Letters will be translated to number when performing a call (e.g. ABC = 2 & DEF = 3).
This should allow companies to show a Phone Number that is readable.
Keywords
Phone Number, Mobile, Alphabet, Account, Individual Customer, Letter, Letters , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , CEC-CRM-IND , Individual Customer for SAP Sales/Service Clou , How To