SAP Knowledge Base Article - Public

3365749 - Phone Number Field Contains Alphabetic Characters

Symptom

You are able to save Alphabets in Phone Number field. 

Environment

  • SAP Sales Cloud Version 2
  • SAP Sales and Service Cloud Version 2

Reproducing the Issue

  1. Navigation Menu.
  2. Go to Accounts View.
  3. Open Account 123 (where 123 is the account ID).
  4. In the Phone field, enter alphabetic letters (e.g. ABC).
  5. The Phone Number is saved successfully.

Cause

The alphanumeric or Alphabetical values are valid and required in some cases.

The system only checks the entry for special characters such as "<>.,!§% &(@€". If you enter these characters the system will remove them from the field as they are not valid.

Resolution

Letters will be translated to number when performing a call (e.g. ABC = 2 & DEF = 3).

This should allow companies to show a Phone Number that is readable.

Keywords

Phone Number, Mobile, Alphabet, Account, Individual Customer, Letter, Letters , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , CEC-CRM-IND , Individual Customer for SAP Sales/Service Clou , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0