SAP Knowledge Base Article - Public

3365822 - COD2305 Change on Address sends multiple business partner in one message

Symptom

You have implemented an integration from Cloud for Customer to an on prem system for business partner replication.
If they change same data on the address of an account the customer and all related contacts are sent in one message to the CPI.
After the mapping in the CPI you get the error: E/EA/728/MULTIPLE_IDOCS_NOT_ALLOWED (IDoc SOAP Namespace - Verletzung (MULTIPLE_IDOCS_NOT_ALLOWED))

Environment

Source: byd
Type: Test System
System ID/Name: CLOUD / my362531.crm.ondemand.com
Product version: SAP Cloud for Customer core applications 2305
System managed by: SAP Cloud Tenant
Install base item: my362531.crm.ondemand.com
Sold product: CUSTOMER ONDEMAND

Reproducing the Issue

1. Open an account of a customer that has contact persons maintained.

2. Change same data on the address of an account the customer.

3. See the outbound message fails.

4. Checking the message in CPI shows the following error: E/EA/728/MULTIPLE_IDOCS_NOT_ALLOWED (IDoc SOAP Namespace - Verletzung (MULTIPLE_IDOCS_NOT_ALLOWED))

5. After checking the receiver channel of the Iflow the Receiver Channel of the artifact is set as "Application/x-sap.idoc"

Cause

In the case you have integration with an ERP system due to the requirements on ERP side all contacts are replicated when you update the address. If you also have integration set up to S4 or CRM in addition to ERP then these systems will also receive the extra information in their payloads.

Then if the Receiver Channel (on the iflow) is not properly set up you will run into errors.

Resolution

You must change the Receiver Channel of the artifact from "Application/x-sap.idoc" to "Text/XML"

Keywords

CPI, C4C, Integration, Iflow, Business Partner, address, Replicate Business Partner to SAP Business Suite , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer core applications 2308