SAP Knowledge Base Article - Public

3365879 - Publishing Rule section for Intelligent Services Center event coming up empty - SuccessFactors

Symptom

Publishing Rule tab for some ISC event does not display the Business rule and shows an empty pane instead.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  • Navigate to Intelligent Services Center.
  • Open the impacted Event type.
  • Go to the Publishing Rule tab on the left navigation pane.
  • The business rule corresponding to that event is not being shown, the Rule pane appears empty.

Cause

The Business Rule corresponding to the Event is not maintained with the expected ID.

Resolution

ISC Events require the corresponding Business Rules to be maintained with very specific Rule IDs. The ID text has to be perfect match to what ISC expects, including the Case. Without that ISC will not be able to find the rule to show it on the user interface.
For example: the EMPLOYMENT TERMINATION event will require the corresponding rule to be maintained with Id EVENT_TERM.

In the event there is a Rule ID mismatch for an ISC event, the solution would be to recreate/copy the Rule with the expected ID.

See Also

Copying Rules | SAP Help Portal

Keywords

ISC,Intelligent,Services,Center,Rule,Publishing , KBA , LOD-SF-PLT-ISC , Intelligent Services , Problem

Product

SAP SuccessFactors HXM Suite 2305