SAP Knowledge Base Article - Public

3366285 - 'Unknown' Requester in Administer Time UI

Symptom

Upon accessing the Workbench for an employee, the 'Requester' field has the 'Unknown' value.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HXM Suite

Cause

The user who requested the leave does not have the fields 'First Name' and 'Last Name' populated.

Even though these two fields cannot have the 'Required' set to 'No' under Manage Business Configuration, this can be overridden by adding an employee via Basic User Import. This is not recommended, as behaviors like the one documented on the KBA can be observed and lead to data inconsistency and/or confusion on the audit of records.

Resolution

In order to find who submitted the leave, you can run an Employee Time Audit Report via Integration Center (check 'See Also' section of the KBA):

In this test case, the user who requested the leave is 'ADAPI'. Upon checking their profile, we can see that there's no Personal Information maintained:

As the Personal Information portlet is not Effective Dated, we need to perform a Basic User Import to update the fields in order for them to be synched in Employee Profile. After adding them via Import, we can check the Workbench once again to see that the 'Requested' field has been updated to the added value:

See Also

Keywords

time off, time, off, workbench, administer time, requester field, unknown, successfactors, api, upsert, first name, last name , KBA , LOD-SF-EC-TIM-UI , Team Absence Calender/ Workbench/ ESS UI's , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM suite all versions