Symptom
- When assigning a category to a KB article, once it is saved as draft, the category is no longer assigned.
- I have to re-assign a category to a KB article saved as draft.
Environment
SAP WorkZone
Reproducing the Issue
- Log onto WorkZone
- Go to Knowledge Base.
- Create a KB.
- Add a category to this KB.
- Save the KB as draft.
- See the draft saved but the category that was assigned was removed.
- Edit the KB, see the category is not present here and you will had to add the category again.
Cause
Expected behaviour - the product is intentionally designed this way.
Resolution
- This is expected behaviour and how the product was intentionally designed in order to avoid excessive invalid data generation which in turn would cause further issues with the product if this was permitted.
- Users will need to edit the category at the time of publication for the category to save. It is expected that it will not save when the KB goes into Draft status to avoid excessive data on the system.
- Customers should raise an enhancement request on this topic if they would like to see this feature updated in the future of the product
See Also
Keywords
KB, WorkZone, knowledge base article, knowledge base, article, draft, category, saved, LOD-SF-SWZ-KNB, LOD-SF-SWZ , KBA , LOD-SF-SWZ-KNB , Knowledge bases , Product Enhancement
Product
SAP SuccessFactors Work Zone all versions