Symptom
- You are using the Agent Desktop (AD) (side by side mode)
- When the CTI sends the payload with the ExternalID, and this is viewed under the phone call or chat activity, you realized the GUID is missing the hyphens "-" in it.
- For example:
- The CTI sends "AE2A1E5A-7CFE-4D08-9F93-97BBBA981F9E" in the payload to AD
- However, in the External ID field for the activity, the GUID is captured as AE2A1E5A7CFE4D089F9397BBBA981F9E
Environment
- SAP Service Cloud
- SAP Sales Cloud
- SAP Cloud for Customer
- Agent Desktop (Add-on)
Reproducing the Issue
- Agent accepts a chat or telephone call
- The CTI is sending the ExternalD as ae2a1e5a-7cfe-4d08-9f93-97bbba981f9e (including the hyphens/dashes)
- End the call
- Navigate to the Activities, Phone Calls
- Open the corresponding phone call and expend the header
- Check under the External ID field and compare
Cause
System is working designed
Resolution
- Both, the ExternalReferenceID and ExternalOriginalReferenceID can be maximum of 35 alpha-numeric characters, no special characters, or dashes.
- You need to create a communication system and provide that system ID in the live activity configuration.
- Please refer to the "Phone Events and Payload" online documentation, for more details.
See Also
Keywords
KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2308