Symptom
Groupware Outlook Add-In Server side search show erroneous search values.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Perform a specific search in Add-in. For example: accounts "A".
- You will notice that the search results are way less than what is found in C4C itself.
Cause
Search results are limited to 5 records by design. This value is not customizable.
In addition, server-side integration filters out Accounts, Contacts and Individual Customers which are obsolete or in status "In Preparation".
Resolution
We do understand that the customer may have over 100 records that are valid and would like to be shown in the Add-in, however with current design, it will cause performance issues and that is why additional re-design/implementation would be required. We would be able to show max of 20 records.
With our adjustment (it will be delivered in the future releases - not estimated yet) you will get 20 records of entity account in the Side-bar. However, not 100+ as you state they've got in C4C.
Additionally, from our side, we would advise configuring the search by setting in Profile > Add-in settings > Account Card in a way, so that you can use other attributes to narrow the list of given options, for example by Account ID.
For that, the improvement should be submitted on the influence portal.
Keywords
Groupware; Outlook; Add-In; Server side; search; values; records; results; mismatch; number. , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To