SAP Knowledge Base Article - Public

3367668 - Solution order with a Sales Item does not create sales order after release

Symptom

The lifecycle status of a Solution Order is "Released". Upon checking the transaction history, no further documents have been created or processed.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Logon to the launchpad with Role SAP_BR_SOLN_ORDER_SPCLST assigned.
  2. Open app Manage Solution Orders.
  3. Select [Create].
  4. Enter the Sold-to party and a Sales Item data.
  5. [SAVE].
  6. Access the Solution Order at a later date and [Release all items].
  7. No Sales order is created.

Cause

The Requested Delivery date for the sales item has been maintained in the past comparable to the solution order creation date. 

Resolution

  1. Open the Solution Order.
  2. Edit the problematic sales item
  3. Maintain the Requested Delivery date as either the present date or any future date.
  4. Release the item.
  5. Assuming the document present no errors the distribution should be successful and the follow-up sales order should be created.
  6. In the Solution Order click the 'Refresh' button, which can be used to see the latest distribution status.

Keywords

C_BUSSOLUTIONORDER, SAP_BR_SOLN_ORDER_SPCLST, VBAK, VA03, sales order item, SOR, SolOrd, F4615, solution order, solution , KBA , CRM-S4-SOL-SLO , S4CRM: Solution Order , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions