Symptom
When using the "Contracts with Invoice Schedules" report, you notice that one or more users cannot see any values in the field "Invoice Schedule Item Invoice Date".
Environment
SAP Business ByDesign
Reproducing the Issue
Logged in as the affected user, follow these steps:
- Go to the Sales Orders Work Center.
- Open the Reports View.
- Find the Report: Contracts with Invoice Schedules.
- Open the Report.
- Run the Report.
You notice that the field "Contracts with Invoice Schedules" is not showing any values.
When running this report as another user with different authorizations, the data is then fetched correctly for this field.
Cause
In order for the data in field "Invoice Schedule Item Invoice Date" to be displayed, the user running the report needs to have unrestricted access to Work Center CRM_CONTRACTS_SALES in their Access Rights.
Resolution
These are the steps that need to be followed to assign unrestricted access to work center CRM_CONTRACTS_SALES for the user:
- Go to the Application and User Management Work Center.
- Open the Business Users View.
- Find user ABC (Where ABC Represents the ID of the affected user).
- Click on Edit and then Access Rights.
- Navigate to the Access Restrictions tab
- Find Work Center View ID CRM_CONTRACTS_SALES
- Change the Read Access to Unrestricted.
- Save and Close.
Keywords
Report, Access Rights, Restricted, Write, Read, View, Unable, Blank, Empty, Value, Field , KBA , AP-SLO-SO , Sales Order , How To