SAP Knowledge Base Article - Public

3368085 - Service contract creation ends with error in CL_SDBIL_PARTNER_HDLR_ABSTR-RAISE_INCONSISTENT_PRT

Symptom

When executing job: "Schedule Billing Document Request Creation" the following error is raised:
Error in CL_SDBIL_PARTNER_HDLR_ABSTR-RAISE_INCONSISTENT_PRT: Partner address data for function Bill-to Party inconsistent

Environment

  • Service Management (CRM)
  • SAP S/4HANA Cloud All versions

Reproducing the Issue

  1. Logon to the launchpad with role SAP_BR_CUSTOMER_SRVC_MGR assigned.
  2. Open app: 'Schedule Billing Document Request Creation'.
  3. Fill in required parameters.
  4. Run job.
  5. Check the Job Log.
  6. An error is displayed: Error in CL_SDBIL_PARTNER_HDLR_ABSTR-RAISE_INCONSISTENT_PRT: Partner address data for function Bill-to Party inconsistent.

Cause

The business partner is not valid for period.

Resolution

Please check the validity date (valid from) of the business partner. It maybe that the billing date does not fall into a valid period of the business partner.

Keywords

SAP_S4CRM_BC_SERV_CONTR_PC, F3780, 3MO, enter a valid address number, ADRNR, SERV_CONTR, ship-to, partner, customer , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions