SAP Knowledge Base Article - Public

3368204 - Unable to Associate Object Multiple Times with Email Activity

Symptom

When you try to associate an object e.g. Case with an email activity multiple times, you receive either the error Some of the entered objects are already associated or Selected object is already present.

Environment

SAP Service Cloud Version 2.

Reproducing the Issue

  1. Navigate to the Emails work center.
  2. Select any email activity.
  3. Navigate to the Related Entities tab.
  4. Click Add Related Entities.
  5. Choose any object e.g. Case.
  6. Manually type in a Case ID that is already associated with the email.
  7. See the error Some of the entered objects are already associated.
  8. If you still try to associate the case by other ways, you may also see the error Selected object is already present.

Cause

By standard, a specific object can only be associated against each email activity a single time only. If you try to assign the same object that is already assigned, then the error will be displayed accordingly.

Resolution

This is the system designed behavior.

Keywords

Email, Emails, E-mail, E-mails, SAP Service Cloud Version 2, Related Entities, Related, Entities, Case, Case ID, Multiple, Associate, Error, Error Message, Selected object is already present, Some of the entered objects are already associated, Object, Objects, , KBA , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , How To

Product

SAP Service Cloud Version 2 all versions