Symptom
After the 2308CE upgrade, using the app Manage Customer Master Data, when you try to make any change in Contact Person, system throws an error, causing no change in Contact Person.
At least one Customer Role required to maintain Additional Information
Environment
SAP S/4HANA Cloud 2308
Reproducing the Issue
- Go to the app Manage Customer Master Data
- Filter by Contact Person
- Select any Contact Person
- Click on Edit
- Make any change in the Contact, for example in the field Search Term 1
- Save
- The changes are not saved and the system throws the error
Cause
This is the designed behavior.
Resolution
This is an intended feature that SAP does not want to allow creation of Business Partner without Customer role in Manage Customer Master Data app. The app Manage Customer Master Data is designed to create and maintain only Business Partners with Customer Role. To manage non customer roles for example Contact Person, use the app Manage Business Partner Master Data or the app Maintain Business Partner.
Keywords
Customer, Role, Maintain Business Partner, Business Partner, Contact, Contact Person, Additional Information, Fiori app , KBA , LO-MD-FIO-CM , Fiori UI for Customer Master , Problem
Product
SAP S/4HANA Cloud 2308