SAP Knowledge Base Article - Public

3368574 - Custom Party Role Not Available to be Added to a Case Party Schema

Symptom

When trying to add a custom party role created to any of your case party schemas, you notice the role is not available to be selected.

Environment

SAP Service Cloud Version 2.

Reproducing the Issue

  1. Click on the User Menu.
  2. Click Settings.
  3. Navigate to All Settings.
  4. Click Party Roles, under Party Processing.
  5. Create a new custom party role, adding all relevant details.
  6. Save the changes.
  7. Click Party Schema, under Cases.
  8. Select any schema.
  9. Click Edit.
  10. Click on the + icon to add a new custom party role.
  11. See the party created is not displayed.

Cause

The custom party role was created with a Category which is not supported for the case party schema, hence, it is not available to be selected.

Resolution

At the moment, the following party role categories are supported for case party schema:

  • Custom Account Party
  • Custom Individual Customer Party
  • Custom Contact Person Party
  • Custom Employee Party
  • Custom Supplier Party
  • Custom Supplier Contact Party

When creating a custom party role, ensure that one of the above categories are selected, so that the party will be available for selection.

Keywords

Case, Cases, Party, Party Role, Custom Party Role, Custom Party, Party Schema, Case Party Schema, Category, Party Processing, Add, SAP Service Cloud Version 2, Custom Account Party, Custom Individual Customer Party, Custom Contact Person Party, Custom Employee Party, Custom Supplier Party, Custom Supplier Contact Party, , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-PAP , Party Processing for SAP Sales/Service Cloud , How To

Product

SAP Service Cloud Version 2 all versions