SAP Knowledge Base Article - Public

3368618 - Unable to Upload Mass Certificate for Approving the Sales Quote via Outlook E-mail

Symptom

The user has created an approval process where the Sales Quotes/Sales Orders can be approved directly from an Microsoft Outlook email. But when the user selects the approve option, the mail is drafted for a sender, which displays the message as "Use the certificate which is assigned to your user in the system" and does not provide an option to mass upload the Encryption Certificate.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator Workcenter
  2. Go to Business Users view
  3. Select a Business User ABC
  4. Select Manage Certificate

Observe that you can only upload the certificates individually—not in bulk.

Cause

Individual certificates must be set up for Microsoft Outlook and Multipurpose Internet Mail Extensions (MIME) configuration in order to approve emails.

Resolution

There is currently no functionality that allows the user to mass upload S/MIME certificates for all users; instead, it must be uploaded for each user individually.

In order to approve the order, the user must individually have the certificate downloaded from the Outlook and upload it in Cloud for Customer system following the below steps which authenticates the request and approves the order. 

Steps to Download the Certificate in Outlook for Specific User ABC:

  1. Go to Files in Outlook
  2. Go to Options 
  3. Navigate to the Trust Center 
  4. Select Trust Center Settings
  5. Go to E-mail Security
  6. Navigate to Setting under Encrypted email
  7. Under Certification and Algorithms download the Encryption Certificate

Steps to upload the certificate in the system for that specific user: ABC

  1. Go to Administrator Workcenter
  2. Go to Business Users view
  3. Search and Select the User: ABC
  4. Select Manage Certificate button
  5. Select Upload S/MIME Certificate to upload the Encryption Certificate.

Since it is new requirement, the user can add the request on the Influence page: https://influence.sap.com/sap/ino/#/campaign/1868

If you need this functionality urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

You can find more details about the services offered by Cloud Service Center. You can contact Cloud Service Center as follows:

1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partner finder

2. If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of SAP Application Development site, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.

Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices

Keywords

S/MIME certificates, Encryption Certificate, Microsoft Outlook E-mail , KBA , SRD-CC-SEC , Security , Problem

Product

SAP Cloud for Customer core applications all versions