SAP Knowledge Base Article - Public

3368636 - Manage Automatic Payment Incorrect IBAN used

Symptom

For payment IBAN of house bank (debtor IBAN Number in XML File ) in app Manage Automatic Payments (App ID F0770) is not the same as IBAN maintained in App Manage Bank Accounts (App ID F1366A) for house bank, house bank account, used Manage Automatic Payments

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP S/4HANA Cloud 

Cause

There are two or more bank accounts with the same 18-digit account number but different currencies or extra numbers. The key of table TIBAN (IBAN) contains BANKS (Country/Region Key of Bank), BANKL (Bank Keys), BANKN (18-digit Bank Account Number) and BKONT (Bank Control Key). Currency is not part of the key.

Updating bank account with currency example EUR can impact the IBAN of bank account with same 18-digit account number and currency example SAR and vice versa. Then the payment program can get the wrong IBAN when querying table TIBAN with the key.

Resolution

Open App Manage Bank Accounts and search bank account with account number and currency 

Open the object page of the bank account and edit non-critical attribute like Account Description of this bank account. Then save it.

Then payment program can find the correct IBAN to execute payment.

Keywords

KBA , FIN-FSCM-CLM-BAM-2CL , Bank Account Management (Public Cloud) , FI-FIO-AP-2CL , Fiori UI for Accounts Payable (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions