SAP Knowledge Base Article - Public

3368676 - Replication Number Range Error

Symptom

You have replicated account and/or contacts from S4Hana system to SAP Sales Cloud and SAP Service Cloud Version 2 which have 8 digit numbers.

In C4C configuration you have updated the Business Partner range intervals accordingly (e.g. 1 - 999999999).

Although you have maintained the number range and expect the same fall into the defined range, you perceive the following error in the Inbound Message Monitoring:

Business Partner ID 12345678 must be outside the internal number range 999999 to 999999999

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to Settings
  2. Under Business Partner tile, click on Number Range
  3. change the Number Ranges intervals as per your requirement.
  4. after replicate the Account ID along within the same interval, you might get the following error in the Web Message Monitoring:

error: Business Partner ID "12345678" must be outside the internal number range "999999 to 999999999"

Although they have maintained the number range as, e.g. "1 - 999999999" system error still says "999999".

Cause

Validation methodology for Number Range updates.

Resolution

We have changed the behavior in a way that once the number range is updated; you should wait for a maximum of 5 minutes before the new range is updated in the validation cache. Number range uses validation cache and this cache was not invalidated earlier and this is the reason the system was still using the old ranges and the validation errors were raised.

Now the validation cache will be updated every 5 mins. So once the ranges are updated; wait for a maximum of 5 mins. 

Keywords

KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-NR , Number Range for SAP Sales/Service Cloud , Known Error

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0