Symptom
When customer is trying to set up the start time and end time at 7:00AM (US/Central) in Proxy Management, it automatically saves to 7:00PM (US/Central) of the previous day. For example, customer set up the Start time of an account holder to June 3, 7:00 AM.
After saving, the start time becomes June 2, 7PM (US/Central) instead of June 3, 7AM (US/Central).
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Environment
SAP SuccessFactors HXM Core
Reproducing the Issue
- Go to Proxy Management
- Look up existing assignments.
- Select any Account Holder then click Edit.
- Modify the start time and make it 7:00 AM (Sample: June 3, 7:00 AM (US/Central)).
- Click save.
- Check the start time and it became 7:00 PM of the previous day (June 2, 19:00 / 7:00 PM (US/Central)).
Cause
The legacy proxy time range handling has a typo. It is currently on 12h format (yyyy-MM-dd hh:mm:ss). However, it should use the 24h format (yyyy-MM-dd HH:mm:ss). 7:00 AM on US/Central is 12:00PM on UTC, the 12h format causes the 12:00PM (UTC) to be read as 12:00AM (UTC) which is 7:00PM on US/Central. Hence, causing the issue.
The date that is saved in DB is correct but the reading and formatting is wrong.
Resolution
This is a known issue and fix would be patched on the B2311 Release. Target date of Release for Preview is October 20, 2023 and the Release for Production is November 17, 2023.
See Also
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