Symptom
When trying to use the interface BusinessPartnerHierarchySimpleReplicationIn you get an error that looks like the following "ID mapping for Account XXXXXXXX missing".
Environment
Cloud for Customer
Reproducing the Issue
- Navigate to the Administrator work centre > General Settings > Web Message Monitor
- Look up the failed message
- Click of the message then restart.
- Refresh the monitor to see if the error is still occuring.
Cause
BusinessPartnerHierarchySimpleReplicationIn message failed because the payload contains a BP which does not have ID mapping properly maintained in C4C.
In this case the BP is present but there is no external ID for the entry.
Resolution
Please make sure the BP's are replicated first from ERP system before BusinessPartnerHierarchy message is sent.
For the following payload:
<BusinessPartnerHierarchySimple>
<BusinessPartnerInternalID>XXXXXXXX</BusinessPartnerInternalID>
<BusinessPartnerInternalIDTypeCode>918</BusinessPartnerInternalIDTypeCode>
<ParentBusinessPartnerInternalIDTypeCode>918</ParentBusinessPartnerInternalIDTypeCode>
The issue was occurring due to the fact that there was no external ID maintained for Account (typecode 918 f the type code is instead 888 search for Business partner in the ID mapping instead of ERP account) for the entry. After entering an external ID to complete the entry in the ID mapping for integration the replication via BusinessPartnerHierarchySimpleReplicationIn works.
Keywords
BusinessPartnerHierarchy , BusinessPartnerHierarchySimpleReplicationIn , account, ERP, C4C, Cloud for Customer, Replciation, Integration, ID Mapping , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem