Symptom
When the new pronoun value is selected and saved in employee profile, this new Pronoun value is not updating in the employee profile.
Environment
SAP SuccessFactors Employee Central: Employee Profile
Reproducing the Issue
1. Go to employee profile;
2. In the header information, go to "My Profile" > Select one of the pronouns from "How to refer to you" in the dropdown menu.
3. After changing the pronoun, click on "Save";
4. Refresh the page;
5. See that the new pronoun does not reflect in the profile.
Cause
Misconfiguration for Pronouns. To guarantee seamless integration between Employee Central and other SAP SuccessFactors modules, Employee Profile is updated with information stored in Employee Central. Some Employee Profile attributes are updated online when changes are recorded in Employee Central data. Other attributes are only updated when the HRIS synchronization process is run. Employee Central changes that are entered as of a future date are reflected in Employee Profile as soon as the HRIS synchronization process is run after the future date has been reached.
Resolution
The first step is review the current pronouns configuration. If pronouns are configured as HRIS mapping fields and the sample user is an EC user, these pronouns are not editable from People Profile UI and can only be updated by the HRIS sync process to avoid data discrepancy.
According to the handbook section HRIS Sync Configuration Between Employee Central and Employee Profile: "To avoid data discrepancy, the HRIS mapping fields in this block are editable only for non-Employee Central users. For Employee Central users, these fields aren't editable from UI and can only be updated by the HRIS sync process."
See Also
HRIS Sync Configuration Between Employee Central and Employee Profile;
3288155 - Pronoun is not visible in Employee Profile;
Enabling Pronouns
Keywords