SAP Knowledge Base Article - Public

3371151 - TicketReplication FSM Failing Time Efforts

Symptom

When integrating FSM with C4C, you notice the following errors at the Web Service Message Monitoring:

-Agent CL_APCRM_SRQ_REPL_IPA has triggered a fatal error
-Locking object not possible; object locked by XXXX (XXXX is the user ID)
-Operation not possible; business document locked

Environment

SAP Cloud for Customer

Cause

For the C4C and FSM integration to work the pre-requisite is that the master data should have been replicated within the systems.
In case of Time Efforts, one of the master data that needs to be replicated from C4C to FSM is the "Employee". This error is caused when the party "PartyID" is blank in the message payload This should not be blank as the C4C time entry has to be created against an Employee.

Resolution

Please check the following:

1) If the employee was correctly created in C4C and replicated to FSM or not.

2) If yes, then please check if you have done any Iflow modifications etc due to which the PartyID could be blank. If yes, please review and make sure the PartyID is being passed.

Keywords

Failing; Missing; Problem; Red;  , KBA , LOD-CRM-SRP-CSI , Integration of service ticket with Core systems , How To

Product

SAP Cloud for Customer core applications all versions