SAP Knowledge Base Article - Public

3371179 - Social Media Provider ID is required Error When Closing the Email Channel Screen

Symptom

You receive the error Social Media Provider ID is required, when Closing the Email Channel Screen.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Select the Service and Social view.
  3. Open Email Addresses.
  4. Click New.
  5. Add your own email address so you can verify it easily.
  6. Verify the channel.
  7. Activate the channel.
  8. Click on Close on the bottom of the screen.
  9. Say Yes on the prompt.
  10. Error "Social Media Provider ID is required" is seen.

Cause

This is a standard limitation when clicking on the button Close. The oficial guidance for now is to click on "Save and Close" during the Email Channel initial creation process. 

Resolution

This is planned to be enhanced in the future C4C releases.

Keywords

Social Media; Email; Ticket Type; ID; Validation;  , KBA , LOD-CRM-SC-EML , Email , How To

Product

SAP Cloud for Customer core applications all versions