Symptom
You receive the error Social Media Provider ID is required, when Closing the Email Channel Screen.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Select the Service and Social view.
- Open Email Addresses.
- Click New.
- Add your own email address so you can verify it easily.
- Verify the channel.
- Activate the channel.
- Click on Close on the bottom of the screen.
- Say Yes on the prompt.
- Error "Social Media Provider ID is required" is seen.
Cause
This is a standard limitation when clicking on the button Close. The oficial guidance for now is to click on "Save and Close" during the Email Channel initial creation process.
Resolution
This is planned to be enhanced in the future C4C releases.
Keywords
Social Media; Email; Ticket Type; ID; Validation; , KBA , LOD-CRM-SC-EML , Email , How To
Product
SAP Cloud for Customer core applications all versions