SAP Knowledge Base Article - Public

3371596 - Search is Agent Desktop is missing Contacts when compared to C4C

Symptom

  • You perform a search in Agent Desktop (Add-on) and noticed it is missing some accounts, when compared to C4C search
  • This does not happen for all accounts/contacts relationships just few
  • You would like to better understand the reason for this issue

Environment

  • SAP Service Cloud
  • SAP Sales Cloud
  • Agent Desktop (Add-On)

Reproducing the Issue

  1. In C4C, go to Customers -> Accounts
  2. Search for an account that has multiple Contacts associated to it, for example Account ABC123 has 13 Contacts
  3. Go to Services -> Agent Desktop
  4. Search for the same account, and notice that under Contacts, there is only 10 Contacts displayed and not 13 as expected
  5. While comparing the two, you noticed the following Contacts missing:
    1. John Dow A.
    2. Jane Dow
    3. John Dow B.

Cause

System working as designed

Resolution

  • Check the Contacts and ensure that these are not maintained as "Main" Contacts for other Accounts.
    • Contacts can only be counted once against an account if the contact is not maintained as a primary contact for another account.
    • Only contacts that are not marked as Main Contacts connected to other accounts will be shown
  • If the above is correct, meaning the contacts are not defined as Main Contacts for other Accounts, then raise a Support Case.
    • Reason:
      • There could be missing data in Agent Desktop, requiring a new initial Load for Business Partner Relationship.
      • A re-indexing of the data could be needed.

Keywords

Agent Desktop, Agent Console, Side by side, count, business partners, comparison, contacts, accounts, customers , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem

Product

SAP Cloud for Customer core applications 2308