Symptom
- You perform a search in Agent Desktop (Add-on) and noticed it is missing some accounts, when compared to C4C search
- This does not happen for all accounts/contacts relationships just few
- You would like to better understand the reason for this issue
Environment
- SAP Service Cloud
- SAP Sales Cloud
- Agent Desktop (Add-On)
Reproducing the Issue
- In C4C, go to Customers -> Accounts
- Search for an account that has multiple Contacts associated to it, for example Account ABC123 has 13 Contacts
- Go to Services -> Agent Desktop
- Search for the same account, and notice that under Contacts, there is only 10 Contacts displayed and not 13 as expected
- While comparing the two, you noticed the following Contacts missing:
- John Dow A.
- Jane Dow
- John Dow B.
Cause
System working as designed
Resolution
- Check the Contacts and ensure that these are not maintained as "Main" Contacts for other Accounts.
- Contacts can only be counted once against an account if the contact is not maintained as a primary contact for another account.
- Only contacts that are not marked as Main Contacts connected to other accounts will be shown
- If the above is correct, meaning the contacts are not defined as Main Contacts for other Accounts, then raise a Support Case.
- Reason:
- There could be missing data in Agent Desktop, requiring a new initial Load for Business Partner Relationship.
- A re-indexing of the data could be needed.
- Reason:
Keywords
Agent Desktop, Agent Console, Side by side, count, business partners, comparison, contacts, accounts, customers , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2308