Symptom
All the keys from the form have been mapped, but not all digits from the key are being mapped. For example, a telephone number with a 3-digit area code is only being displayed with 2 digits.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Go to Onboarding Home dashboard.
- Find the candidate in the work queue that was facing the issue.
- Click on the 3 dots next to the candidate's name and click in Documents.
- Open the document that did not populate the field correctly.
- The field will not be populated correctly.
Cause
There are two possible reasons for this issue:
- The fields were not configured correctly.
- The box field where you enter the value is too small.
Resolution
Scenario 1:
- Please verify that the field experiencing population issues was configured correctly.
- By comparing it with a similar field that is functioning properly, any inconsistencies in the configuration can be identified and corrected as needed.
Scenario 2:
- If the configuration is correct for the field, verify whether the box size in the original form is sufficient to store all digits.
- Comparing the box field size of other keys that are populating correctly can help determine the ideal size to ensure all data is entirely populated.
Keywords
Onboarding, ONB, Onboarding 1.0, form, fields, populate, key, PDF, keys, mapped, digits, box, population, document , KBA , LOD-SF-OBD-FRM , Country Compliance Forms , Problem
Product
SAP SuccessFactors Onboarding all versions
Attachments
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SAP Knowledge Base Article - Public