Symptom
You have created purchase orders with service items where there is a delivery start date and delivery end date.
But when you create the Purchase Order item completion run with delivery date criteria within certain period, the system picks up all the purchase orders even though delivery end date does not fulfill the criteria specified in the run.
You expect the system to consider end date of the service period as delivery date and not the delivery start date shown in items tab.
Environment
SAP Business By Design
Reproducing the Issue
-
Go to Purchase Requests and Orders work center
-
Select Purchase Order Item Completion Runs view
-
Select the specific Run id which is active
(criteria: e.g. Expected delivery before: X Day(s))
- Check the application log
- Purchase Orders whose delivery end date is not before X days are also completed via this run.
Cause
System will pick the delivery expected from date only i.e. the start date of delivery, so if the start date of delivery falls within the criteria (expected delivery before) , then system will pick those orders.
The delivery start date is the one specified in the item level as well.
Resolution
This is the standard system behavior.
You can post in customer influence forum if you want to change this behavior: https://influence.sap.com/sap/ino/#/campaign/886.
This is our official channel to address all new requirements. If multiple customers vote for the same idea, our development team will check the feasibility of implementing this functionality in future.
You can track the idea and check the status of the idea in that forum.
Keywords
Purchase Order Item Completion Runs, Expected delivery before, purchase order delivery date, delivery start date, delivery end date , KBA , AP-POP-PO , Purchase Order , Problem