SAP Knowledge Base Article - Public

3372582 - Delete all session checkbox on Login Page of C4C

Symptom

Use of Delete all sessions checkbox available on the login page of C4C

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Login to C4C.

2. Open any workcenter and perform any operation (in this case Contacts workcenter - Quick Create).

3. Now without logging off open the application in another browser window. 

4. Once you provide your credentials and click logon you will get a "delete all sessions checkbox" in the login page. 

5. You select the delete all sessions checkbox and login. 

6. Now if you try to perform any operation in the previously opened tab (in this case save operation - Contacts workcenter - Quick Create) you will get a session time out error.

 

Cause

This is an expected behavior.

The selection of the delete all session check box while logging in will terminate the user from using the view in the previously opened tab. However, this is an application session timeout that is the user can continue to use other views and workcenters (in this case anything other than Contacts workcenter) and can also use the existing view in the read-only mode (in this case Contacts workcenter).

Resolution

If you wish to have multiple sessions up and running for all purposes, then do not select the "delete all sessions" checkbox while logging in to the application.

Keywords

Delete All Sessions, Multiple login sessions, 400 session timeout , KBA , AP-RC-UIF , C4C UI Framework , Problem

Product

SAP Cloud for Customer core applications all versions