SAP Knowledge Base Article - Public

3372641 - Payment Advice is Not in the Second Step of the Bank Statement

Symptom

You have created a payment advice via standard web service and the document has been successfully created in the system. However, when you try to select the payment advice in the second step of the bank statement, you will find that the newly created payment advice is not in the list.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Application and User Management work center.
  2. Go to Service Explorer view.
  3. Search for Web Service Name: ManageBankAdviceIn.
  4. Download the WSDL file and enter the required information in the file.
  5. Login to SOAP UI.
  6. Execute ManageBankAdviceIn web service to create payment advice, e.g. payment advice 123(123 represents the payment advice ID).
  7. Then go to Liquidity Management work center.
  8. Go to Bank Statements view.
  9. Create a new bank statement.
  10. In the second step, you find that the newly created payment advice 123 is not in the list.

Cause

You have included the payment reference information in the payload. Once you have entered the payment reference in the payment advice, you won't be able to see the payment advice in the second step of the bank statement.

'<PaymentReference>

<ID>XXX</ID>

</PaymentReference>'

You can also check the payment advice 123 in the system and will notice that this field is filled.

Resolution

This is the designed system behavior. Please check if you need to modify the payload by deleting the relevant information.

Keywords

Payment Advice, Payment Reference, Web Service, Maintain Bank Advices, , KBA , SRD-FIN-CLM , Cash and Liquity Managment , Problem

Product

SAP Business ByDesign all versions