Symptom
When you create a new routing rule, the conditions dropdown list has duplicate fields.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Activity Planner
- Go to Routing Rules
- Create New
- Save and Open
- Go to Conditions
- Add
- Observe: Fields are duplicated in the dropdown list, e.g : Distribution Channel appears 3 times in the list
Cause
There is a workflow Ec (WorkflowCondition_EC) involved.
Duplicate fields can display under Workflow Conditions if there are fields (made by KUT/PDI) with the same name.
Resolution
Under the workflow conditions, any fields created in KUT/PDI with the same name as standard will be shown as duplicates. You can either delete or rename the KUT/PDI duplicated fields.
Keywords
Workflow Condition; duplicate fields; routing rules, activity planner; conditions , KBA , LOD-CRM-ACT-ROT , Activity Routing , How To
Product
SAP Cloud for Customer core applications 2308