Symptom
In "Project Control - Enterprise Projects" app, below error message appears when system tries to propose the next possible project ID,
if high volume of projects starting with similar long prefix and project ID exists in the system:
"At the moment we can’t save or autosave".
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to app "Project Control - Enterprise Projects".
- Create a new project.
- Enter a prefix in the field Project ID and the error appears.
Cause
While creating a new project, when there is a high volume of projects or WBS elements with their IDs starting with a given prefix,
the system takes a long time to loop through the IDs to propose the next sequential ID.
The screen might not respond in such situations and could throw an error message.
For example, if you enter M in the Project ID then the system could propose M4YG4135015252 if it is the next sequential ID that does not exist in the DB.
If it exits, then the system continues looping till it finds the next available ID.
Resolution
To overcome this lock situation the user can either enter the complete project ID in one go, or use a prefix followed by alphanumeric characters other than long prefix that is already used.
For example, if M4YG4135015252 is the sequence that is used then it is recommended to use a different prefix such as MA followed by the desired characters.
Keywords
Project Control, Project ID, next available ID, available, At the moment we can’t save or autosave, no response , KBA , PS-FIO-STR-2CL , Fiori UI for Project Systems-Structures (Public Cloud) , Problem