Symptom
While searching for new users to add to a Dynamic Team, no results are showing for some active users.
Environment
SAP SuccessFactors Dynamic Teams
Reproducing the Issue
- Open Dynamic Teams
- Select a team and choose Team Members tab
- Click on '+' Add Team Member button
- Search for any user
- 'There were no results' message is visible
Cause
New team member doesn't have permission 'Create, View and Edit Dynamic Teams' in RBP, which grants access to Dynamic Team page.
Users without access to Dynamic Teams page cannot be added as Team members.
Resolution
Make sure that the following permissions are granted to the users:
- User adding the new team member:
- "Create, View and Edit Dynamic Teams" under User Permissions > Dynamic Teams;
- "User Search" under User Permissions > General User Permission > Company Info Access (new team member must be within permission role's target population).
- new team member:
- "Create, View and Edit Dynamic Teams" under User Permissions > Dynamic Teams.
Keywords
Dynamic Teams, add, new, member, search, DT, DYT, There were no results, Create, View and Edit Dynamic Teams , KBA , LOD-SF-DT-ADM , Admin Center, RBP, Permissions and Settings , Problem
Product
SAP SuccessFactors HCM Suite all versions