Symptom
After enabling the 'Company Exit Date' field in your environment and running a Full HRIS Sync to sync it from the Termination Date for employees, you notice the field has not synced for some terminated employees (with a Termination Date in their Employment Details) and is still empty
Environment
SAP SuccessFactors HXM Suite
SuccessFactors Employee Central
Reproducing the Issue
- Enable the 'Company Exit Date' field in your environment
- Run a Full HRIS Sync to sync the exit date from the (terminated) employee's Termination Date
- Go to the employee's profile, see the 'Company Exit Date' field is still empty despite the sync running correctly without any errors, and the employee having a Termination Date in their Employment Details
Cause
The employee has an invalid or inactive Manager, which is preventing the sync from being successful
Resolution
In order to resolve the issue, do a Basic User Import for the terminated employees and change their 'MANAGER' column to 'NO_MANAGER', so they have no Manager maintained instead of having an invalid/inactive one.
Then, run a User-Based Full HRIS Sync job for the employees, and the Company Exit Date should sync successfully for them.
See Also
Company Exit Date, company-exit-date, companyexitdate, sync, not syncing, empty, blank, termination, termination date
Keywords
KBA , LOD-SF-EC-TER , Termination Details , LOD-SF-EC-HRS , HRIS Sync , Problem