SAP Knowledge Base Article - Public

3374022 - Inactive LMS Items Showing in WorkZone Search Results

Symptom

Inactive LMS Items Showing in WorkZone search results.

Environment

SAP SuccessFactors Learning

SAP SuccessFactors WorkZone

Reproducing the Issue

  1. In LMS, make sure to deactivate an item.
  2. Now access Work Zone.
  3. In the very first page, type "LMS_ITEM_KEYWORD" in the search bar.
  4. Note that some External Objects will load.
  5. Click on the "LMS_ITEM_KEYWORD" result found
  6. An error will pop up "could not open app. please try again later."

Cause

There is no update sent to WorkZone to inform that the item was deactivated in the LMS side. This is currently a product limitation from WorkZone as confirmed by WZ Engineering.

Resolution

A potential workaround is to disable the following setting in the WorkZone side which will disable all LMS items from displaying in the WorkZone search. Please navigate to:

  1. WorkZone Admin Console>
  2. External Integrations>
  3. External Solutions>
  4. Find Learning integration>
  5. Disable "Enable global search for business records and related feed conversations".
  6. Save it.

*Please note that this workaround will disable all LMS items from displaying in the search.*

Keywords

WorkZone, Learning Items, Inactive Item, search inactive item worzone, learning inactive item workzone search, workzone search, search, inactive. , KBA , LOD-SF-LMS-WZ , LMS WorkZone Integration , Product Enhancement

Product

SAP SuccessFactors Learning all versions ; SAP SuccessFactors Work Zone all versions